Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - FYG71

Pages: [1]
1
Electronic Organs / Re: Musicom organ system
« on: August 03, 2020, 10:58:51 PM »
I emailed Musicom but got no response I’m afraid.

2
Electronic Organs / Re: Musicom organ system
« on: July 30, 2020, 08:36:06 PM »
I have since learned that the system has to be programmed to accept the new stops and so it looks like the Musicom system might have to give way to some replacement midi driver boards.  A pity really seeing as at least the capture side is still working.

3
Electronic Organs / Musicom organ system
« on: July 27, 2020, 02:34:28 PM »
I have a Norwich organ which dates from 1990 and uses the Musicom system.  The tone generation side of the organ has expired (not a problem as I want to use an external tone source) but the capture system remains intact and workable.  The organ is 2 manual and I would like to add a third manual with 8 stops (for which I have matching drawstops ready to go and compatible keyboards) My questions are:
1.  There appears to be space on the capture boards to accommodate the extra 8 stops, so should it be as simple as wiring them in?  The boards with Darlington transistors appear to have selector switches at the bottom to ‘channel’ the system.
2.  The Musicom system uses 8x8 matrix for scanning keys and pedals.  It is possible to add midi to the existing system easily or is it best to bypass with a stand-alone encoder?

Thanks in anticipation

4
Electronic Organs / Re: Ahlborn H5 voice issue
« on: April 11, 2016, 06:31:03 PM »
Thanks for all the helpful advice so far.  Sadly, work commitments call again this week but I hope to investigate further at the weekend.

Will update when I have some results...hopefully of a positive nature! ;D

Cheers

5
Electronic Organs / Re: Ahlborn H5 voice issue
« on: April 09, 2016, 02:52:06 PM »
The fault isn't common to all voices, only those from the respective chip sets.  I am going to try an oscilloscope to see if I can trace where the fault begins in the circuit.  The outputs do eventually merge into a 3 channel system but not before going through preamp stages.

6
Electronic Organs / Re: Ahlborn H5 voice issue
« on: April 08, 2016, 09:26:08 AM »
Worth a try to see if there are any poor connections.  I also have a chip lifting tool but it may be too small for larger ones. 
There was a fair amount of fluff inside the organ, mostly the same colour as a fabric cover that someone had lovingly made. 
Everything else functions perfectly on the organ.  It is such a pity that some of the tone generation is affected.  I had wondered if there was a simple way of checking the output signal with a different amplifier by tapping in to the output pins from the board just to check that the fault definitely lives on the generator side rather than the power amp board (where I found a failed and a blown capacitor (both replaced now).

Thanks for all the helpful comment so far.  :)

7
Electronic Organs / Re: Ahlborn H5 voice issue
« on: April 07, 2016, 12:44:24 PM »
Thanks for the answers.  The battery does not seem to have leaked at all, in fact, the processor board looks very clean.  The chips are in sockets and so could probably be removed and replaced, presuming that replacements could be sourced (I understand that spare parts are no longer available for this model from Ahlborn uk, don't know if this includes chips as well?)

I haven't probed anything as yet.  I did wonder whether the preamp side of the amplifier board might cause such symptoms?  The headphone and line out circuits appear to lead off after each line out for each division has passed through op amp chips of their own, which seem to then link together.

8
Electronic Organs / Ahlborn H5 voice issue
« on: April 05, 2016, 05:54:28 PM »
Hello
I recently acquired an Ahlborn H5 one manual organ (1994 vintage) which has a curious fault.  Although a one manual organ, the stop voices are drawn from 3 chips and circuits from the digital processor board.  The stops from chip 1 all speak without issue.  Those from chip 2 all speak with harmonic distortion and those from chip 3 are barely inaudible.  I have completed a factory re-set but this hasn't cured the problem.  I also checked the on-board battery for leakage (a common problem apparently, which destroys the processor board) but this is intact. 

The distorted stops and those which are silent also behave in this way when heard through the external outputs and headphones and so I think the problem lies in the processor board rather than in the power amplifier side. 

Has anyone experienced this issue before who might be able to give some advice?  I have a copy of the schematic and some electronics experience in terms of replacing components.  It seems a shame to not try to fix this instrument as the rest is in good order.

I did have to replace the main capacitors on the power board as one had shorted out and also noted that the mains plug wiring had a very loose earth connection!  All fixed now.

Pages: [1]


Locations of visitors to this page

Organ Design


Latroba Holidays